Jumper EZBOOK 3 Pro mit M2 SSD

Am 27.07.2018 habe ich mir Jumper EZBOOK 3 pro von Gearbest geliefert bekommen. Das Windows 10 vom 64GB eMMC-Speicher funktioniert ohne größere Probleme.

Bei der M.2-SSD war es da schon schwiriger, diese zum Laufen zu bekommen. Mein erster Versuch mit der „Toshiba RC100 Series M.2 NVMe 240GB“ ist gescheitert. Weder BIOS noch Windows 10 hat diese erkannt. Der Grund dafür ist relativ einfach. Das Jumper EZBOOK 3 pro unterstützt NVMe nicht. Es kann nur SATA M.2 Karten ansprechen. Da in der Baugröße 2242 die Auswahl nicht besonderst groß ist habe ich mich für die KingSpec NT-256 (256GB für ca. 50$) entschieden. Windows 10 konnte die Karte erst nach 2-3 Neustarts formatieren.

Nach dem Formatieren habe ich die SSD mit h2test geprüft. Sie war soweit in Ordnung.

Mein Arch-Linux habe ich wie gewohnt (dmcrypt, lvm, btrfs, …) auf die M.2-Karte installiert. Die EFI-Partion mit Grub habe ich ebenfalls auf die M.2-Karte gelegt. Im BIOS habe ich dann den GRUB von der M.2-Karte als erstes Boot-Device eingestellt. Das hat dann bis zum ersten Ausschalten funktioniert. Danach hat das BIOS die M2-Karte nicht mehr erkannt und das Windows vom eMMC gebootet. Nach ein paar Neustarts war die M2-Karte wieder da und ich konnte mein Arch-Linux booten.

Ein blick in DMESG „ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)“ und „ata1: limiting SATA link speed to 3.0 Gbps“ hat mir gezeigt, das die Karte mit S-ATA3 (6,0GBit/sec) nicht klar kommt. Bei S-ATA2 (3,0 Gbit/sec) läuft die Karte ohne Probleme. libata.force=3.G als weiteren Boot-Parameter im Grub hat das S-ATA-Problem nach dem Booten gelöst. Leider hilft der Parameter nicht, dem Bios die M.2-Karte zu finden.

Durch die On/Off Beziehung von der M.2-Karte war im BIOS immer der Windows-Bootloader eingestellt. Deshalb musste der Grub auf den eMMC-Speicher. Ich habe mit gparted die Windows-Partion um 512 MB verkleinert und eine zweite EFI-Partion im eMMC angelegt. Die Vorhandene EFI-Partion (100MB) war zu klein für GRUB+Kernel. Wenn man vom Ausgeschalteten System direkt in den GRUB (eMMC) bootet, bricht dieser ab, weil er die M.2-Karte nicht findet.

Was aktuell zuverlässig funktioniert ist:

  1. Laptop einschalten
  2. Ins Bios gehen
  3. Discard and Reboot auswählen
  4. GRUB vom eMMC das Linux (oder Windows) booten lassen
  5. libata.force=3.G als Boot-Paramter sorgt dafür, das es keine ATA Fehler gibt

Danach läuft Stundenlang alles Stabil. Reboot geht auch ohne Probleme. Der Wechsel von Win10 zu Linux funktioniert auch einwandfrei. Nur nach dem Ausschalten muss ich wieder 1x ins BIOS, damit die M.2-Karte gefunden wird.

Kann man in dem Unlocked-BIOS die SATA-Geschwindigkeit von der M.2-Karte auf 3,0 Gbps einstellen? (Antwort Bitte als Kommentar, Kontakt-Formular oder eMail zusenden)

Sollte jemand Fragen an mich haben oder einen Lösung für das Problem kennen, einfach einen Kommentar hinterlassen oder eine e-Mail senden.

Begriffsklärung:
Ausschalten: Länger wie >1 min ausgeschaltet (z.B. über Nacht)
Reboot: Neustart oder nur ganz kurz aus < 30 sec.

Bios-Datum: 02/01/2018

Let’s Encrypt Script

Ich habe in meinem Let’s Encrypt Script (Version 06) zwei neue Funktionen eingebaut.
Man kann jetzt Konfigurations-Dateien anlegen. Das Script arbeitet sich beim Ausführen durch alle Konfigurationsdateien durch.

Die Zertifikate werden nur noch erneuert, wenn Sie X* Tage vor dem Ablaufdatum sind.
* frei Einstellbar (RENEWDAYS)

Details / Download: https://www.thju.de/bash-scripte/lets-encrypt/

0
Getagged mit: , ,

Crosstrainer

Ich habe mir einen Crosstrainer zugelegt. Mal schauen ob jetzt mit dem Sport besser klappt.

Crosstrainer

1+

GPS-Mid: Europa, Frankreich, Android

Ich habe mal wieder einige neue Karten erstellt. Es gibt jetzt Karten für viele Europäische Länder, welche ich aber nur gelegentlich manuell aktualisiere. Frankreich habe ich ähnlich wie Deutschland in die Regionen aufgeteilt. Leider reicht für eine Region der RAM-Speicher von meinen Server nicht. Bei 2 anderen Regionen hatte ich einen Tippfehler in meinem Script. Das nächste mal sollten diese dann dabei sein.

Android: Ich habe auch mal die Android-Version zu GPS-Mid erstellt. Ich konnte diese mangels Hardware aber nicht Testen, also viel Spaß beim ausprobieren.

PS: Die Übersichtsseite muss ich noch aktualisieren.

0
Getagged mit: , , ,

DSL: Annex J

Ich habe seit dem 24.07.2014 DSL 6000 RAM mit Annex J von der Telekom. Mein Upload ist von 45kB/sec auf 250kb/sec gestiegen. Der Download ist con 375kB/sec auf 600kB/sec gestiegen. Der Ping hat sich von 55 ms auf 25 sec reduziert. IPv6 habe ich jetzt auch nativ. Der 24h Disconnect ist jetzt auch weg. Leider muss jetzt jetzt per VOiP Telefonieren und habe kein ISDN mehr. Bis jetzt konnte ich das aber noch keine Nachteile feststellen. Die Umstellung hat sich für mich bis jetzt gelohnt.

0
Getagged mit: ,

GpsMid: Diverse europäische Länder

So… ich habe mal angefangen noch einige europäische Länder zu generieren für GpsMid. Aktuell ist die Liste der Länder noch relativ kurz:

Österreich, Belgien, Tschechische Republik, Dänemark, Finnland, Luxemburg, Polen, Portugal, Schweiz.

Weiter Länder-Wünsche bitte als Kommentar hinterlassen. Ich werde dann die Machbarkeit prüfen.

0

IPv6 geht wieder

So…. IPv6 ist jetzt eingerichtet und sollte funktionieren.

Beim Einrichten (Debian 7.0 – Wheezy) gabs nur ein kleines komisches Problem.

Die Schreibweise mit „netmask 64“ in der „/ect/network/interfaces“ hat bei mir nicht funktioniert.

Die Scheibweise mit „/64“ am Ende hat mein Problem gelöst:

Warum die Schreibweise mit „netmask 64“  nicht funktioniert hat, weiß ich auch nicht. In den meisten Anleitungen, welche ich gefunden habe, wird diese verwendet.

PS: Das mit den mehren IPv6 Adressen funktioniert bei mir. Der Server ist unter beiden Adressen erreichbar.

 

0

Tool der Woche: Firewall Builder

Mit Firewall Builder kann man sich sehr einfach eine Firewall in einer grafischen Anwendung zusammen klicken. Nach dem Erstellen von der Firewall kann man sich diese in den unterschiedlichsten Formten ausgeben lassen (z.B. Linux iptables, …).

0

Neuer vServer

Nach dem Umbau und dem Umzug muss ich jetzt auch noch den vServer von NetCup auf KVM migieren. Die Seite wird also über das Wochenende (19.04.2013 – 21.04.2013) nur Teilweise verfügbar sein. Die GPS-Mid Karten werden noch ein paar Tage länger davon betroffen sein.

 

UPDATE: Der Umzug ist soweit abgeschlossen. IPv6 fehlt noch, wird aber bald nachgereicht.

0

Umzug

Diese Seite wird ab dem 29.03.2013 unter http://www.thju.de erreichbar sein. Die Domain http://blog.thju.de wird dann nicht mehr erreichbar sein.

UPDATE: Der Umzug ist abgeschlossen 🙂

0
Top