Kategorie: Allgemein

Blogs ohne besonders Thema

Ab dem 22.03.2019 bzw. 23.03.2019 wurde über das EPG (Astra) etwas ausgestahlt, was den Kathrein UFS 922 SW Sat-Receiver beschädigt.

Beim Einschalten / Booten schaltet sich der Receiver nach einigen Sekunden wieder aus. Stecker ziehen hat auch nicht geholfen. Der Receiver bootet nicht.

Ich konnte den Receiver auf die folgende Art wiederbeleben:

  1. Firmware downloaden und auf einen FAT32 USB-Stick speichern (Anleitung von Kathrein beachten)
  2. Receiver vom Strom Trennen
  3. USB-Stick mit Firmware anschließen
  4. Receiver an den Strom anschließen und einschalten.
  5. Nach einer kurzen Wartezeit habe ich an dem Knopf gedreht und gelegentlich drauf gedrück
  6. Er hatt dann das Booten beendet. Das EPG war leer.

Wenn man ihn danach das EPG aktuallisieren lässt, ist er wieder kaputt. Also gleich das EPG soweit wie möglich abschalten. Ob der die Firmware beim Starten aktuallisiert hat konnte ich nicht nachvollziehen. Wichtig ist nur, das er das EPG wegschmeißt. Ich habe beschlossen, das wiederbelete Gerät erstmal 2-3 Wochen ungenutzt im Eck stehen zu lassen und schauen ob noch eine neue Firmwareversion kommt.

Meine Firmware-Version: 2.10

PS: Ich wollte das 10 Jahr alte Gerät schon auf den Müll schmeißen, da ich zuerst an ein Hardware-Problem gedacht habe. Wenn dein Receiver zufällig auch an dem Tag kaputt gegangen ist, dann Probier meine Anleitung oder wende die an den Kathrein-Support.…

Am 27.07.2018 habe ich mir Jumper EZBOOK 3 pro von Gearbest geliefert bekommen. Das Windows 10 vom 64GB eMMC-Speicher funktioniert ohne größere Probleme.

Bei der M.2-SSD war es da schon schwiriger, diese zum Laufen zu bekommen. Mein erster Versuch mit der „Toshiba RC100 Series M.2 NVMe 240GB“ ist gescheitert. Weder BIOS noch Windows 10 hat diese erkannt. Der Grund dafür ist relativ einfach. Das Jumper EZBOOK 3 pro unterstützt NVMe nicht. Es kann nur SATA M.2 Karten ansprechen. Da in der Baugröße 2242 die Auswahl nicht besonderst groß ist habe ich mich für die KingSpec NT-256 (256GB für ca. 50$) entschieden. Windows 10 konnte die Karte erst nach 2-3 Neustarts formatieren.

Nach dem Formatieren habe ich die SSD mit h2test geprüft. Sie war soweit in Ordnung.

Mein Arch-Linux habe ich wie gewohnt (dmcrypt, lvm, btrfs, …) auf die M.2-Karte installiert. Die EFI-Partion mit Grub habe ich ebenfalls auf die M.2-Karte gelegt. Im BIOS habe ich dann den GRUB von der M.2-Karte als erstes Boot-Device eingestellt. Das hat dann bis zum ersten Ausschalten funktioniert. Danach hat das BIOS die M2-Karte nicht mehr erkannt und das Windows vom eMMC gebootet. Nach ein paar Neustarts war die M2-Karte wieder da und ich konnte mein Arch-Linux booten.

Ein blick in DMESG „ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)“ und „ata1: limiting SATA link speed to 3.0 Gbps“ hat mir gezeigt, das die Karte mit S-ATA3 (6,0GBit/sec) nicht klar kommt. Bei S-ATA2 (3,0 Gbit/sec) läuft die Karte ohne Probleme. libata.force=3.G als weiteren Boot-Parameter im Grub hat das S-ATA-Problem nach dem Booten gelöst. Leider hilft der Parameter nicht, dem Bios die M.2-Karte zu finden.

Durch die On/Off Beziehung von der M.2-Karte war im BIOS immer der Windows-Bootloader eingestellt. Deshalb musste der Grub auf den eMMC-Speicher. Ich habe mit gparted die Windows-Partion um 512 MB verkleinert und eine zweite EFI-Partion im eMMC angelegt. Die Vorhandene EFI-Partion (100MB) war zu klein für GRUB+Kernel. Wenn man vom Ausgeschalteten System direkt in den GRUB (eMMC) bootet, bricht dieser ab, weil er die M.2-Karte nicht findet.

Was aktuell zuverlässig funktioniert ist:

  1. Laptop einschalten
  2. Ins Bios gehen
  3. Discard and Reboot auswählen
  4. GRUB vom eMMC das Linux (oder Windows) booten lassen
  5. libata.force=3.G als Boot-Paramter sorgt dafür, das es keine ATA Fehler gibt

Danach läuft Stundenlang alles Stabil. Reboot geht auch ohne Probleme. Der Wechsel von Win10 zu Linux funktioniert auch einwandfrei. Nur nach dem Ausschalten muss ich wieder 1x ins BIOS, damit die M.2-Karte gefunden wird.

Kann man in dem Unlocked-BIOS die SATA-Geschwindigkeit von der M.2-Karte auf 3,0 Gbps einstellen? (Antwort Bitte als Kommentar, Kontakt-Formular oder eMail zusenden)

Sollte jemand Fragen an mich haben oder einen Lösung für das Problem kennen, einfach einen Kommentar hinterlassen oder eine e-Mail senden.

Begriffsklärung:
Ausschalten: Länger wie >1 min ausgeschaltet (z.B. über Nacht)
Reboot: Neustart oder nur ganz kurz aus < 30 sec.

Bios-Datum: 02/01/2018

Ich habe mir einen Crosstrainer zugelegt. Mal schauen ob jetzt mit dem Sport besser klappt.

Crosstrainer

So…. IPv6 ist jetzt eingerichtet und sollte funktionieren.

Beim Einrichten (Debian 7.0 – Wheezy) gabs nur ein kleines komisches Problem.

Die Schreibweise mit „netmask 64“ in der „/ect/network/interfaces“ hat bei mir nicht funktioniert.

Die Scheibweise mit „/64“ am Ende hat mein Problem gelöst:

Warum die Schreibweise mit „netmask 64“  nicht funktioniert hat, weiß ich auch nicht. In den meisten Anleitungen, welche ich gefunden habe, wird diese verwendet.

PS: Das mit den mehren IPv6 Adressen funktioniert bei mir. Der Server ist unter beiden Adressen erreichbar.

 …

Nach dem Umbau und dem Umzug muss ich jetzt auch noch den vServer von NetCup auf KVM migieren. Die Seite wird also über das Wochenende (19.04.2013 – 21.04.2013) nur Teilweise verfügbar sein. Die GPS-Mid Karten werden noch ein paar Tage länger davon betroffen sein.

 

UPDATE: Der Umzug ist soweit abgeschlossen. IPv6 fehlt noch, wird aber bald nachgereicht.…

Diese Seite wird ab dem 29.03.2013 unter http://www.thju.de erreichbar sein. Die Domain http://blog.thju.de wird dann nicht mehr erreichbar sein.

UPDATE: Der Umzug ist abgeschlossen :-)…

Ich baue mein Blog zu meiner Webseite aus. Das wird noch ein bisschen dauern, aber wenn es fertig ist, soll endlich mal mehr Inhalt kommen!…

Heute (Fr. 13.07.2012) um ca. 11 Uhr gab es einen Brand in einer Schreinerei in Hilsbach. Die ersten Einsatzkräfte von der Feuerwehr erreichten den Einsatzort um 11:16 Uhr. Ungefähr 1 Stunde später war das Feuer gelöscht.

Verletzte gab es keine. Es entstand nur Sachschaden.…

So… es ist mal wieder ein Lug-Camp. Diesmal sind wir schon Mittwochs angereist. Mal schauen, was ich so alles über das Camp basteln werde.…

Ich wünsche euch allen ein gutes neues Jahr!…